Welcome to Web Hosting Forum - Net Hosting Talk

Register now and be part of our community! When you register with the Net Hosting Talk you can join in with topics, start new topics, and generally be a part of the first level of our community. It's also quick and totally free, so what are you waiting for?

Websites on my server are not loading

StacyNex

Newbie
Messages
6
Reaction score
0
Hi,

I wanted to ask for help I'm having problems with my Cpanel / whm server the same this online, but the sites are falling and turned. All firewall settings are configured correctly, so I ran the following command (netstat -plan | grep: 80 | awk '{print $ 5}' | cut -d: -f 1 | sort | uniq -c | sort -nk 1) which shows me a lot of ips connected to port 80 and I believe that this is causing the sites to be getting off even though the ping is normal. is changing port 80 can resolve the issue or it is some type of DDOS attack?

Thank you
 

rachel_toor

Newbie
Messages
6
Reaction score
0
You need to check the server's resources, in addition to the security part, you may be suffering from some type of denial attack that makes the server off for some time.

If you are using any DC, see if they help with this, as for the server resources, you will have to analyze and resolve yourself if necessary.
 

r9host

Newbie
Messages
8
Reaction score
0
If your browser times out connecting to the server when trying to load your website, then your server is running out of resources while serving the page. If this is the case, you need to check if your server via top command to see if your server is continuously under high load or CPU/RAM usage goes high just when trying to load a page.

If resource usage is continuously high, then you may be under attack. You can then try to configure the firewall (e.g. CSF) to limit connections in a period of time (e.g. CONNLIMIT setting in CSF) to control the maximum number of connections in every minute.

If resource usage goes high and connection to the server times out everytime you load the page, then this most likely an issue with resource usage of your website. If you are running WordPress or any other PHP-written CMS, you may need to go for one of options below:

1) Check if the memory_limit setting is configured properly for your website.
2) Check if a plugin is exhausting the memory or CPU.
3) Check if current server resources are totally enough for your CMS and your website.
 

StacyNex

Newbie
Messages
6
Reaction score
0
I believe it was a DDoS attack. I have moved my website to the new provider as the old provider was not able to handle the DDoS attack. Now my websites are normal.

Thank you, everyone, for the help :)
 

Advertisement

Top