Failed to install Let's Encrypt certificate

Our discussions on Web Hosting that will tell you everything you need to know. Find advice, questions and answers on the who's, what's, when's and where's of the Web Hosting world.
Post Reply
phantrọng
Newbie
Posts: 4
Joined: Sun Nov 05, 2017 10:24 am

Wed Nov 29, 2017 1:26 pm

Hello, 

When i try to enable autoSSL for a particular domain, it does not install the certificate. It seems that some file inside the folder ".well-known" does not exist or is this same. please help.
Last edited by phantrọng on Wed Nov 29, 2017 1:45 pm, edited 1 time in total.


User avatar
geniushost
Junior Member
Posts: 24
Joined: Mon Nov 13, 2017 1:34 pm

Wed Nov 29, 2017 1:37 pm

Your .htaccess rules seem to be preventing the certificate from installation. Try adding the following code to the top of the .htaccess file in "public_html" folder:

Code: Select all

<IfModule mod_rewrite.c>
RewriteCond %{REQUEST_URI} !(.well-known) [NC]
</IfModule>

Regards
phantrọng
Newbie
Posts: 4
Joined: Sun Nov 05, 2017 10:24 am

Wed Nov 29, 2017 1:46 pm

Fixed: The error was due to the fact that the system could not access the files inside the .well-know folder due to restrictions in the .htaccess

Thank you @"geniushost"
neckozenica
Junior Member
Posts: 13
Joined: Tue Nov 14, 2017 4:09 am

Wed Dec 06, 2017 8:05 am

hi,

Check your .htaccess file for redirects. If there are complete matches for the entire domain, this won't be compatible with the Let's Encrypt challenge.
If it's not within your .htaccess file, within Plesk go to the domain and then Apache and nginx Settings.

If you have a blanket redirect, remove it and add it using the following guide: Plesk Onyx HTTPS redirect .
HostXNow
Junior Member
Posts: 16
Joined: Fri Feb 16, 2018 8:07 am
Contact:

Fri Feb 16, 2018 8:17 am

The only usual reason for these not to work is when the domain is not pointing properly.
Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 0 guests